INETD not calling my program
Last Post 22 Mar 2013 03:46 PM by Brad. 2 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
Brad
Advanced Member
Advanced Member
Posts:462
Avatar

--
22 Mar 2013 11:07 AM

I wrote a process to use a socket through INETD. It worked great, I could telnet to test it and I was very happy with the results. Of course it has taken two months for the upper powers to ok going to production. Today INETD is not calling my program.

I have no idea where to look to see what might have changed to cause this.

the inetd.conf file has not changed, the service table entry is correct, the socket connects but my program isn't called.

 

Help?

Ringer
Veteran Member
Veteran Member
Posts:1765
Avatar

--
22 Mar 2013 12:51 PM
Do you mean your *INETD program is not being called? Was STRTCPSVR SERVER(*INETD) run? Did the job start? Is the inetd.conf user profile still *ENABLED, and does NOT have *SECADM nor *ALLOBJ authorities? Do you see your port number listening via the NETSTAT command?

Or do you mean your *INETD *PGM object is running, but is not doing an external CALL? If that's the case, put that batch job in debug and step through it. You can set a Service Entry Point via RDi or from a green screen http://www.itjungle.com/fhg/fhg1003...ory01.html .

Chris Ringer
Brad
Advanced Member
Advanced Member
Posts:462
Avatar

--
22 Mar 2013 03:46 PM
It was a password issue with the userid set in the inetd.conf record. :)
You are not authorized to post a reply.

Acceptable Use Policy