RMTOUTQ with OKIdata 521
Last Post 25 Jan 2013 07:58 AM by kvol2000. 9 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
kvol2000
Basic Member
Basic Member
Posts:79

--
23 Jan 2013 06:57 AM

We have an OKIdata microline 521 configured as a remote outq. The printer is in IBM PP emulation mode and HPT is set to IBM4201 (I have also tried OKI321IBM). We are printing forms that are 7 inches long (6 LPI makes it 42 lines long). These forms are "receipts" so one spooled file is one page long. Everything is fine except after it prints the printer ejects a form, wasting one form each time. When I send a spooled file with multiple pages (I tested a 10 page spool) it prints all pages correctly, but then ejects a form after printing. Any suggestions to eliminate the page ejection after printing would be appreciated.

Thanks


Emmanuel
Veteran Member
Veteran Member
Posts:806
Avatar

--
23 Jan 2013 07:33 AM

This is a very helpful web site for setting up printers:

http://www-01.ibm.com/support/docvi...250053649f

Cheers,

Emmanuel

kvol2000
Basic Member
Basic Member
Posts:79

--
23 Jan 2013 10:02 AM

Yes that is a very helpful site and I use it every time I setup a Remote OUTQ printer. I have it configured according to the instructions and it still ejects one page after the spooled file is printed.

Any other ideas?


Carel Teijgeler
Basic Member
Basic Member
Posts:141

--
24 Jan 2013 06:52 AM
Does it really have to be a problem with the definition of the RMTOUTQ? Is this nor an OVRFLW problem or a SKIPB issue?

Regards,
Carel Teijgeler
kvol2000
Basic Member
Basic Member
Posts:79

--
24 Jan 2013 07:34 AM

I don't think it can be an OVRFLW or SKIPB issue because if send one spooled file with say 10 pages, it prints correctly for all ten pages, then it ejects a page after printing, wasting one form. It wouldn't be a major problem except this is used by a POS program and prints a receipt (one spooled file with one page) each time and the printer ejects a page after each receipt.

The page length (form) is 7 inches long (6 LPI makes 42 lines), and after the spooled file completes it ejects exactly one form and is lined up correctly on the next form. So the printer recognizes the page size, it just ejects one page after the spool. Here is my configuration.

Work with Output Queue Description     
                                                             
Queue:   GSP2           Library:   QUSRSYS          

Status:                                          
  Writer active  . . . . . . . . . . . :   Y     
  Writer name(s) if active . . . . . . :   GSP2  
  Output queue held  . . . . . . . . . :   N     
Maximum spooled file size:                       
  Number of pages  . . . . . . . . . . :   *NONE 
  Starting time  . . . . . . . . . . . :         
  Ending time  . . . . . . . . . . . . :         
Writers to autostart . . . . . . . . . :   1     
Display any file . . . . . . . . . . . :   *NO   
Job separators . . . . . . . . . . . . :   0     
Operator controlled  . . . . . . . . . :   *YES  
Order of files on queue  . . . . . . . :   *FIFO 
Data queue . . . . . . . . . . . . . . :   *NONE 
  Library  . . . . . . . . . . . . . . :         
                                                             
Authority to check . . . . . . . . . . :   *OWNER            
Remote system  . . . . . . . . . . . . :   *INTNETADR        
 Remote printer queue . . . . . . . . . :   LPT1_TEXT         
 Queue for writer messages  . . . . . . :   QSYSOPR           
  Library  . . . . . . . . . . . . . . :     QSYS            
Connection type  . . . . . . . . . . . :   *IP               
Internet address . . . . . . . . . . . :   192.168.21.215    
Destination type . . . . . . . . . . . :   *OTHER            
Host print transform . . . . . . . . . :   *YES

Manufacturer type and model  . . . . . :   *OKI321IBM 
Workstation customizing object . . . . :   QWPOKI320  
  Library  . . . . . . . . . . . . . . :     QSYS     
Image configuration  . . . . . . . . . :   *NONE      
Destination options  . . . . . . . . . :   XAUTO XAIX 
                                                      
                                                      
Print separator page . . . . . . . . . :   *NO        
User defined option  . . . . . . . . . :   *NONE      
User defined object:                                  
  Object . . . . . . . . . . . . . . . :   *NONE      
    Library  . . . . . . . . . . . . . :              
  Object type  . . . . . . . . . . . . :              
User driver program  . . . . . . . . . :   *NONE      
  Library  . . . . . . . . . . . . . . :

Spooled file ASP . . . . . . . . . . . :   *SYSTEM                     
Text description . . . . . . . . . . . :   GS Okidata  microline 521

Emmanuel
Veteran Member
Veteran Member
Posts:806
Avatar

--
24 Jan 2013 09:20 AM

I was thinking the same thing as Carel. Does the output work correctly on another printer?

(I don't think the fact that 10 pages prints without an extra page eject between pages proves that it's not an issue with the print file.)

Cheers,

Emmanuel

kvol2000
Basic Member
Basic Member
Posts:79

--
24 Jan 2013 10:39 AM

Yes it prints correctly at another printer. I can create 5 individual spooled files all of them 1 page each. I send them to the oki printer and it will print a blank page between each of them (5 plank pages). I send the same 5 spooled files to an IBm6400 and the print as they should with no skipped pages in between.

 

Brian Rusch
Advanced Member
Advanced Member
Posts:553

--
24 Jan 2013 12:19 PM
Perhaps the problem is with the workstation customizing object (QWPOKI320). The Retrieve WSCST source (RTVWSCST) command will dump the contents into a source file, but I have no idea how to make sense of it. (Google is your friend)
Peder Udesen
Advanced Member
Advanced Member
Posts:542

--
25 Jan 2013 02:25 AM
What is the settings of the OKI printer?
For example if "Skip Over Perforation" is set to Yes.

Try to copy the spoolfile to a physical file with the control character *FCFC and investigate the content.
Read about it here:
http://www.itjungle.com/mgo/mgo0718...ory02.html
It could be that your program is doing a line feed after writing on the very last line thus forcing a form feed.

Regards
Peder
kvol2000
Basic Member
Basic Member
Posts:79

--
25 Jan 2013 07:58 AM

The OKI printer was using a D-LINK DP-301 Plus print server when configured as a RMTOUTQ. I had the RMTPRTQ set to "LPT1_TEXT". I removed the print server and attached it parallel to a PC and started a Client Access session and it works perfectly. This works but I would really like to get it working as a RMTOUTQ.

The "Skip Over Perforation" is set to NO.


You are not authorized to post a reply.

Acceptable Use Policy