Problem with SQL2POI command
Last Post 17 Jan 2013 04:48 AM by gio.cot. 0 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
gio.cot
Basic Member
Basic Member
Posts:281

--
17 Jan 2013 04:48 AM
Hi all
i should create a xls file with filter preloaded for all the colunms; i'm try to use SQL2POI command of SQL2XLS library; but when i run the command :

SQL2POI SQLSTMT('select * from mylib/mufile')
TOXLS('/tmp/aa1.xls')
FROMXLS('/tmp/aa1tmp.xls')
JDEBUG(*YES)

i receive the following errors;

pheraps my poi-2.5.1.jar is too old ? i tried to download the poi-3.2-FINAL-jar, but when i tyry to compile it i receve errrors

can some one help me

Thanks in advance

java.lang.reflect.InvocationTargetException
at java.lang.Throwable.(Throwable.java:240)
at java.lang.Exception.(Exception.java:77)
at java.lang.reflect.InvocationTargetException.(InvocationTargetException.java:54)
at sun.reflect.NativeConstructorAccessorImpl.newInsta nce(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Construc tor.java:274)
at org.apache.poi.hssf.record.RecordFactory.createRec ord(RecordFactory.java:224)
at org.apache.poi.hssf.record.RecordFactory.createRec ords(RecordFactory.java:160)
at org.apache.poi.hssf.usermodel.HSSFWorkbook.(HSSFWorkbook.java:163)
at org.apache.poi.hssf.usermodel.HSSFWorkbook.(HSSFWorkbook.java:130)
at SQL2POI.main(SQL2POI.java:180)
Caused by: java.lang.ArrayIndexOutOfBoundsException
at java.lang.Throwable.(Throwable.java:180)
at java.lang.Exception.(Exception.java:29)
at java.lang.RuntimeException.(RuntimeException.java:32)
at java.lang.IndexOutOfBoundsException.(IndexOutOfBoundsException.java:27)
at java.lang.ArrayIndexOutOfBoundsException.(ArrayIndexOutOfBoundsException.java:26)
at org.apache.poi.hssf.record.UnknownRecord.(UnknownRecord.java:62)
at org.apache.poi.hssf.record.SubRecord.createSubReco rd(SubRecord.java:57)
at org.apache.poi.hssf.record.ObjRecord.fillFields(Ob jRecord.java:99)
at org.apache.poi.hssf.record.Record.fillFields(Recor d.java:90)
at org.apache.poi.hssf.record.Record.(Record.java:55)
at org.apache.poi.hssf.record.ObjRecord.(ObjRecord.java:61)
... 8 more

ERROR: Unable to construct record instance, the following exception occured: null
You are not authorized to post a reply.

Acceptable Use Policy